4 Replies Latest reply: Nov 5, 2018 12:37 PM by Mustafa RSS

    Router will ping, but no internet connectivity?

    Christopher Shoer

      Hi I'm new to this, I'm currently studying CCENT could you have a look and tell me whats wrong, why my router won't connect to the internet when connected via Ethernet0/1 here's my running config:

      PerdysCCNAR1#ping www.google.com

      Translating "www.google.com"...domain server (192.168.178.1) [OK]

       

       

      Type escape sequence to abort.

      Sending 5, 100-byte ICMP Echos to 209.85.203.104, timeout is 2 seconds:

      !!!!!

      Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms

      PerdysCCNAR1#ping www.facebook.com

      Translating "www.facebook.com"...domain server (192.168.178.1) [OK]

       

       

      Type escape sequence to abort.

      Sending 5, 100-byte ICMP Echos to 31.13.73.35, timeout is 2 seconds:

      !!!!!

      Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

      PerdysCCNAR1#ping 192.168.178.1

       

       

      Type escape sequence to abort.

      Sending 5, 100-byte ICMP Echos to 192.168.178.1, timeout is 2 seconds:

      !!!!!

      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

      PerdysCCNAR1#ping 192.168.1.0

       

       

      Type escape sequence to abort.

      Sending 5, 100-byte ICMP Echos to 192.168.1.0, timeout is 2 seconds:

      .....

      Success rate is 0 percent (0/5)

      PerdysCCNAR1#show run

      Building configuration...

       

       

      Current configuration : 1696 bytes

      !

      version 12.3

      service timestamps debug datetime msec

      service timestamps log datetime msec

      service password-encryption

      !

      hostname PerdysCCNAR1

      !

      boot-start-marker

      boot-end-marker

      !

      enable secret 5 $1$cGiN$hMECjXGpp4OhNfk8TMO5M.

      !

      no aaa new-model

      ip subnet-zero

      !

      !

      ip cef

      ip domain name pcrepairsnenagh

      ip name-server 192.168.1.1

      ip name-server 8.8.8.8

      ip name-server 8.8.4.4

      ip dhcp excluded-address 192.168.1.0

      ip dhcp excluded-address 192.168.178.1 192.168.178.30

      !

      ip dhcp pool dpool1

         import all

         network 192.168.1.0 255.255.255.0

         default-router 192.168.178.1

         dns-server 192.168.178.1

         domain-name pcrepairsnenagh.com

      !

      ip dhcp pool perdy

         default-router 192.168.178.1

         dns-server 192.168.178.1

         lease 7

      !

      ip dhcp pool deploy

         network 192.168.178.0 255.255.255.0

         default-router 192.168.178.1

         dns-server 192.168.178.1

      !

      !

      !

      !

      !

      !

      interface Ethernet0/0

      ip address dhcp

      ip nat outside

      half-duplex

      !

      interface Ethernet0/1

      ip address 192.168.0.1 255.255.255.0

      ip nat inside

      full-duplex

      !

      interface Serial1/0

      no ip address

      shutdown

      serial restart-delay 0

      !

      interface Serial1/1

      no ip address

      shutdown

      serial restart-delay 0

      !

      interface Serial1/2

      no ip address

      shutdown

      serial restart-delay 0

      !

      interface Serial1/3

      no ip address

      shutdown

      serial restart-delay 0

      !

      ip nat inside source list NAT-THESE interface Ethernet0/1 overload

      ip http server

      ip classless

      ip route 0.0.0.0 0.0.0.0 192.168.178.1

      !

      !

      !

      ip access-list standard NAT-THESE

      permit 192.168.178.1

      banner motd ^C

      Perdys CCNA  Router, Stay Off This Network^C

      !

      line con 0

      password 7 1511021F0725

      logging synchronous

      login

      line aux 0

      line vty 0 4

      password 7 1511021F0725

      login

      !

      !

      end

       

       

      PerdysCCNAR1#

      PerdysCCNAR1#

      PerdysCCNAR1#conf t

      Enter configuration commands, one per line.  End with CNTL/Z.

      PerdysCCNAR1(config)#int Ethernet0/0

      PerdysCCNAR1(config-if)#duplex full

      PerdysCCNAR1(config-if)#end#

                                ^

      % Invalid input detected at '^' marker.

       

       

      PerdysCCNAR1(config-if)#end

      PerdysCCNAR1#

      *Mar  1 00:42:25.899: %SYS-5-CONFIG_I: Configured from console by console

        • 1. Re: Router will ping, but no internet connectivity?
          Mustafa

          instead

          ip nat inside source list NAT-THESE interface Ethernet0/1 overload

          put

          ip nat inside source list NAT-THESE interface Ethernet0/0 overload

           

          and ACL NAT-THESE

          ============

          ip access-list standard NAT-THESE

          permit 192.168.0.0 0.0.0.255

           

          if you wan to go from inside to outside world

          -----------------------

          ip dhcp excluded-address 192.168.1.0

          ==============================

          ip dhcp excluded-address 192.168.0.1

          ---------------------------------------------------

          ip dhcp pool dpool1

             import all

             network 192.168.0.0 255.255.255.0

             default-router 192.168.178.1

             dns-server 192.168.178.1

             domain-name pcrepairsnenagh.com

          !

          --------------------------------------------------

          ip dhcp pool dpool1

             import all

             network 192.168.0.0 255.255.255.0

             default-router 192.168.0.1

             dns-server 192.168.178.1

             domain-name pcrepairsnenagh.com

           

          good luck

          • 2. Re: Router will ping, but no internet connectivity?
            Christopher Shoer

            Thank you so much I will try that on my router I see where I've went wrong though, thank you so much!

            • 3. Re: Router will ping, but no internet connectivity?
              Christopher Shoer

              Thank you so very much, I really appreciate it. Working like a charm through my switch also, here's my running config incase anyone has similar problems, thank you!

              PerdysCCNAR1#show run

              Building configuration...


              Current configuration : 1761 bytes

              !

              version 12.3

              service timestamps debug datetime msec

              service timestamps log datetime msec

              service password-encryption

              !

              hostname PerdysCCNAR1

              !

              boot-start-marker

              boot-end-marker

              !

              enable secret 5 $1$cGiN$hMECjXGpp4OhNfk8TMO5M.

              !

              no aaa new-model

              ip subnet-zero

              !

              !

              ip cef

              ip domain name pcrepairsnenagh

              ip name-server 192.168.1.1

              ip name-server 8.8.8.8

              ip name-server 8.8.4.4

              ip dhcp excluded-address 192.168.1.0

              ip dhcp excluded-address 192.168.178.1 192.168.178.30

              ip dhcp excluded-address 192.168.0.1

              !

              ip dhcp pool dpool1

                 import all

                 network 192.168.0.0 255.255.255.0

                 default-router 192.168.0.1

                 dns-server 192.168.178.1

                 domain-name pcrepairsnenagh.com

              !

              ip dhcp pool perdy

                 default-router 192.168.178.1

                 dns-server 192.168.178.1

                 lease 7

              !

              ip dhcp pool deploy

                 network 192.168.178.0 255.255.255.0

                 default-router 192.168.178.1

                 dns-server 192.168.178.1

              !

              !

              !

              !

              !

              !

              interface Ethernet0/0

              ip address dhcp

              ip nat outside

              full-duplex

              !

              interface Ethernet0/1

              ip address 192.168.0.1 255.255.255.0

              ip nat inside

              full-duplex

              !

              interface Serial1/0

              no ip address

              shutdown

              serial restart-delay 0

              !

              interface Serial1/1

              no ip address

              shutdown

              serial restart-delay 0

              !

              interface Serial1/2

              no ip address

              shutdown

              serial restart-delay 0

              !

              interface Serial1/3

              no ip address

              shutdown

              serial restart-delay 0

              !

              ip nat inside source list NAT-THESE interface Ethernet0/0 overload

              ip http server

              ip classless

              ip route 0.0.0.0 0.0.0.0 192.168.178.1

              !

              !

              !

              ip access-list standard NAT-THESE

              permit 192.168.178.1

              permit 192.168.0.0 0.0.0.255

              banner motd ^C

              Perdys CCNA  Router, Stay Off This Network^C

              !

              line con 0

              password 7 1511021F0725

              logging synchronous

              login

              line aux 0

              line vty 0 4

              password 7 1511021F0725

              login

              !

              !

              end


              PerdysCCNAR1#

              • 4. Re: Router will ping, but no internet connectivity?
                Mustafa

                you're welcome my friend

                M