1 Reply Latest reply: Nov 5, 2018 9:12 AM by Ing_Percy RSS

    EIGRP over gre tunnel

    Fred

      Hello everyone,

       

      I'm very aware that this question is probably posted many time already. However, I'm absolutely overwhelmed with troubleshooting. For me every seems alright. My problem is that one router drops its EIGRP packets although the destination IP address is a local link.

       

      Here are the configurations of both ends of the tunnel. I have two different eigrp processes because I've hoped another one would do the trick. (It didn't, obviously).

       

      hostname Home

       

      ip dhcp excluded-address 193.0.0.33

      ip dhcp excluded-address 193.0.0.49

      ip dhcp excluded-address 193.0.0.17

      ip dhcp excluded-address 193.0.0.65

      ip dhcp excluded-address 193.0.0.34

      ip dhcp excluded-address 193.0.0.35

      ip dhcp excluded-address 193.0.0.36

      !

      ip dhcp pool ADMIN

      network 193.0.0.16 255.255.255.240

      default-router 193.0.0.17

      dns-server 10.0.23.24

      ip dhcp pool Management

      network 193.0.0.32 255.255.255.240

      default-router 193.0.0.33

      dns-server 10.0.23.24

      ip dhcp pool Guest

      network 193.0.0.48 255.255.255.240

      default-router 193.0.0.49

      dns-server 10.0.23.24

      !

      ip cef

      no ipv6 cef

      !

      !

      license udi pid CISCO2901/K9 sn FTX1524KKSX

      !

      spanning-tree mode pvst

      !

      !

      interface Tunnel0

      ip address 10.1.1.1 255.255.255.252

      mtu 1476

      tunnel source Serial0/2/1

      tunnel destination 22.64.192.1

      !

      !

      interface GigabitEthernet0/0

      ip address 192.0.23.129 255.255.255.192

      duplex auto

      speed auto

      !

      interface GigabitEthernet0/1

      no ip address

      duplex auto

      speed auto

      !

      interface GigabitEthernet0/1.10

      encapsulation dot1Q 10

      ip address 193.0.0.17 255.255.255.240

      !

      interface GigabitEthernet0/1.20

      encapsulation dot1Q 20

      ip address 193.0.0.33 255.255.255.240

      !

      interface GigabitEthernet0/1.30

      encapsulation dot1Q 30

      ip address 193.0.0.49 255.255.255.240

      !

      interface GigabitEthernet0/1.40

      encapsulation dot1Q 40 native

      ip address 193.0.0.65 255.255.255.240

      !

      interface Serial0/2/0

      ip address 192.0.23.241 255.255.255.252

      encapsulation ppp

      clock rate 2000000

      !

      interface Serial0/2/1

      ip address 192.0.23.246 255.255.255.252

      encapsulation ppp

      !

      interface Serial0/3/0

      no ip address

      clock rate 2000000

      shutdown

      !

      interface Serial0/3/1

      no ip address

      clock rate 2000000

      shutdown

      !

      interface Vlan1

      no ip address

      shutdown

      !

      router eigrp 25

      passive-interface GigabitEthernet0/0

      passive-interface GigabitEthernet0/1

      network 192.0.23.128 0.0.0.63

      network 193.0.0.0 0.0.0.127

      network 192.0.23.244 0.0.0.3

      network 192.0.23.240 0.0.0.3

      network 10.1.1.0 0.0.0.3

       

      !

      router eigrp 1

      passive-interface GigabitEthernet0/0

      passive-interface GigabitEthernet0/1

      network 192.0.23.240 0.0.0.3

      network 10.1.1.0 0.0.0.3

      network 192.0.23.128 0.0.0.63

      network 192.0.23.244 0.0.0.3

       

      !

      ip classless

      ip route 22.64.192.1 255.255.255.255 Serial0/2/1

      !

      ip flow-export version 9

      !

       

      !

      line con 0

      !

      line aux 0

      !

      line vty 0 4

      login

      !

      end

       

       

      routing table of Router Home:

       

      Home(config)#do show ip route

      Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

       

      Gateway of last resort is 192.0.23.245 to network 0.0.0.0

       

        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

      C 10.1.1.0/30 is directly connected, Tunnel0

      L 10.1.1.1/32 is directly connected, Tunnel0

        22.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

      D 22.64.192.0/27 [90/2681856] via 192.0.23.245, 00:12:02, Serial0/2/1

      S 22.64.192.1/32 is directly connected, Serial0/2/1

        192.0.23.0/24 is variably subnetted, 12 subnets, 3 masks

      C 192.0.23.128/26 is directly connected, GigabitEthernet0/0

      L 192.0.23.129/32 is directly connected, GigabitEthernet0/0

      D 192.0.23.224/30 [90/2681856] via 192.0.23.245, 00:12:03, Serial0/2/1

      D 192.0.23.228/30 [90/2681856] via 192.0.23.242, 00:12:02, Serial0/2/0

      D 192.0.23.232/30 [90/2681856] via 192.0.23.242, 00:12:02, Serial0/2/0

      D 192.0.23.236/30 [90/2681856] via 192.0.23.242, 00:12:02, Serial0/2/0

      C 192.0.23.240/30 is directly connected, Serial0/2/0

      L 192.0.23.241/32 is directly connected, Serial0/2/0

      C 192.0.23.242/32 is directly connected, Serial0/2/0

      C 192.0.23.244/30 is directly connected, Serial0/2/1

      C 192.0.23.245/32 is directly connected, Serial0/2/1

      L 192.0.23.246/32 is directly connected, Serial0/2/1

      D 192.0.24.0/24 [90/2684416] via 192.0.23.242, 00:12:02, Serial0/2/0

        193.0.0.0/24 is variably subnetted, 8 subnets, 2 masks

      C 193.0.0.16/28 is directly connected, GigabitEthernet0/1.10

      L 193.0.0.17/32 is directly connected, GigabitEthernet0/1.10

      C 193.0.0.32/28 is directly connected, GigabitEthernet0/1.20

      L 193.0.0.33/32 is directly connected, GigabitEthernet0/1.20

      C 193.0.0.48/28 is directly connected, GigabitEthernet0/1.30

      L 193.0.0.49/32 is directly connected, GigabitEthernet0/1.30

      C 193.0.0.64/28 is directly connected, GigabitEthernet0/1.40

      L 193.0.0.65/32 is directly connected, GigabitEthernet0/1.40

      D*EX 0.0.0.0/0 [170/7289856] via 192.0.23.245, 00:12:02, Serial0/2/1

       

      EIGRP Neighbors:

       

      Home(config)# do show ip eigrp neighbors

      IP-EIGRP neighbors for process 25

      H Address Interface Hold Uptime SRTT RTO Q Seq

        (sec) (ms) Cnt Num

      0 192.0.23.245 Se0/2/1 14 00:12:50 40 1000 0 30

      1 192.0.23.242 Se0/2/0 14 00:12:49 40 1000 0 27

       

      IP-EIGRP neighbors for process 1

      ________________________________________

       

      Office Router

       

      Outside(config)#do show r

      Building configuration...

       

      Current configuration : 1357 bytes

      !

      version 15.1

      no service timestamps log datetime msec

      no service timestamps debug datetime msec

      no service password-encryption

      !

      hostname Outside

      !

      !

      ip cef

      no ipv6 cef

      !

      !

      license udi pid CISCO2901/K9 sn FTX15248F2Q

      !

      spanning-tree mode pvst

      !

      !

      interface Tunnel0

      ip address 10.1.1.2 255.255.255.252

      mtu 1476

      tunnel source Serial0/2/0

      tunnel destination 192.0.23.146

      !

      !

      interface GigabitEthernet0/0

      ip address 10.0.0.1 255.255.0.0

      duplex auto

      speed auto

      !

      interface GigabitEthernet0/1

      ip address 193.0.0.129 255.255.255.128

      duplex auto

      speed auto

      !

      interface Serial0/2/0

      ip address 22.64.192.1 255.255.255.224

      encapsulation ppp

      clock rate 2000000

      !

      interface Serial0/2/1

      no ip address

      clock rate 2000000

      shutdown

      !

      interface Serial0/3/0

      no ip address

      clock rate 2000000

      shutdown

      !

      interface Serial0/3/1

      no ip address

      clock rate 2000000

      shutdown

      !

      interface Vlan1

      no ip address

      shutdown

      !

      router eigrp 25

      passive-interface GigabitEthernet0/1

      network 10.1.1.0 0.0.0.3

      network 193.0.0.128 0.0.0.127

       

      !

      router eigrp 1

      passive-interface GigabitEthernet0/1

      network 10.1.1.0 0.0.0.3

      network 192.0.0.128 0.0.0.127

      network 192.0.23.0

       

      !

      ip classless

      ip route 0.0.0.0 0.0.0.0 Serial0/2/0

      !

      ip flow-export version 9

      !

      !

      line con 0

      !

      line aux 0

      !

      line vty 0 4

      login

      !

      !

      !

      end

       

      Outside(config)#do show ip route

      Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

       

      Gateway of last resort is 0.0.0.0 to network 0.0.0.0

       

        10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks

      C 10.0.0.0/16 is directly connected, GigabitEthernet0/0

      L 10.0.0.1/32 is directly connected, GigabitEthernet0/0

      C 10.1.1.0/30 is directly connected, Tunnel0

      L 10.1.1.2/32 is directly connected, Tunnel0

        22.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

      C 22.64.192.0/27 is directly connected, Serial0/2/0

      L 22.64.192.1/32 is directly connected, Serial0/2/0

      C 22.64.192.2/32 is directly connected, Serial0/2/0

        193.0.0.0/24 is variably subnetted, 2 subnets, 2 masks

      C 193.0.0.128/25 is directly connected, GigabitEthernet0/1

      L 193.0.0.129/32 is directly connected, GigabitEthernet0/1

      S* 0.0.0.0/0 is directly connected, Serial0/2/0

       

      Outside(config)#do show ip eigrp neighbors

      IP-EIGRP neighbors for process 25

       

      IP-EIGRP neighbors for process 1

       

      v

       

      I would be very thankful if anyone can point out what I did wrong regarding the configuration of the tunnel.

      Cheers